Opened 3 weeks ago

#308 new Defect

FLEXPART-WRF: Sorry t not in [K]

Reported by: lioannidis Owned by:
Priority: major Milestone:
Component: FP other Version: FLEXPART 9.0.2
Keywords: Cc:

Description

Hello everyone,

I am trying to run FLEXPART-WRF backwards, using wrfout files at 100km resolution, with 200 by 200 points.

Initially, I was getting an error link to the number of wind grids in y-direction.
I modified the par_mod.f90 file and more specifically I increased the number of dimensions (nymax).

Since then I am getting an error "Sorry t not in [K]". I found this error message in the ew.f90 function, which is being called, if I am not mistaken, in some of the read modules.

After some digging, I found in readwind.f90 that the model reads some parameters from wrfout files. The error occurs because the subroutine is reading more grids than actually exist in wrfout file for temperature (if I got it right).
I tried to force it to read less grid points but I am still getting the same error.

I am not sure I am looking in the right place to fix this error.
For me it could also be an interpolation error, so I could adjust the time step but I am not sure If that is possible in FLEXPART-WRF.

I doubled-check the wrfout files for any problematic wind, but all the parameters look correct.

Has any of you have ever come across this error? How did you solve it?

Any ideas are more than welcome.

Thank you,
Lefteris

PS: I run FLEXPART-WRF at 20km using 86 by 86 points without any error.

Change History (0)

Note: See TracTickets for help on using tickets.
hosted by ZAMG