Opened 6 years ago

Closed 5 years ago

#74 closed Defect (fixed)

Problem in FLEXPART run with stratospheric ozone tracer option

Reported by: sulinust Owned by: jbrioude
Priority: major Milestone: FLEXPART_WRF_3.2_FPbase_9
Component: FP other Version: FLEXPART-WRF
Keywords: strat o3 tracer Cc: rstow

Description

I have been trying a bunch of test run with FLEXPART-WRF using WRF output data, the results turn out to be reasonable if I set mdomainfill to be 0, but the output concentrations are all 0 if I choose stratospheric ozone tracer option (mdomainfill=2), so I am wondering if anyone could help find out what the problem is, please find the model configuration attached, any help is very much appreciated.

Attachments (4)

flexwrf.input.strat2 (6.5 KB) - added by sulinust 6 years ago.
flexpart input
conccalc_reg.f90 (15.8 KB) - added by jbrioude 5 years ago.
conccalc_reg.2.f90 (15.8 KB) - added by jbrioude 5 years ago.
conccalc_irreg.f90 (15.2 KB) - added by jbrioude 5 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by DefaultCC Plugin

  • Cc rstow added

Changed 6 years ago by sulinust

flexpart input

comment:2 follow-up: Changed 5 years ago by jbrioude

  • Owner changed from somebody to jbrioude
  • Status changed from new to assigned
  • Version changed from FLEXPART 9.0.2 to FLEXPART-WRF

Sorry for the late reply.
Just a reminder: the ozone tracer option is a domain filling option. If used, stratospheric ozone is calculated within the release location you defined based on a Ozone/PV linear relationship above the tropopause.

I see that your release location is too small in your input file. the release location will define the boundaries where the stratospheric ozone is calculated.
The coordinates should define a large release box.
For instance (assuming you use RELEASE_COORD=0)

20110301 000000 ID1, IT1 beginning date and time of release
20110303 000000 ID2, IT2 ending date and time of release
1993500 XPOINT1 (real) longitude [deg] of lower left corner
1021500 YPOINT1 (real) latitude [deg] of lower left corner
4400000 XPOINT2 (real) longitude [deg] of upper right corner
3400000 YPOINT2 (real) latitude [DEG] of upper right corner
1 KINDZ (int) 1 for m above ground, 2 for m above sea level, 3 pressure
0 ZPOINT1 (real) lower z-level
18000 ZPOINT2 (real) upper z-level
1000000 NPART (int) total number of particles to be released

1.000E00 XMASS (real) total mass emitted

test NAME OF RELEASE LOCATION

Can you try that?
Thanks

comment:3 in reply to: ↑ 2 Changed 5 years ago by sulinust

Replying to jbrioude:
Thanks for the reply, I have tried the setting you suggested as well as a even larger release domain, but the output concentrations are still all 0... please see my setting below:

=====================FORMER OUTGRID FILE=====================

  1. OUTLONLEFT geograhical longitude of lower left corner of output grid
  2. OUTLATLOWER geographical latitude of lower left corner of output grid 80 NUMXGRID number of grid points in x direction (= # of cells ) 80 NUMYGRID number of grid points in y direction (= # of cells ) 1 OUTGRIDDEF outgrid defined 0=using grid distance, 1=upperright corner coordinate
  3. DXOUTLON grid distance in x direction or upper right corner of output grid
  4. DYOUTLON grid distance in y direction or upper right corner of output grid 3 NUMZGRID number of vertical levels 500.0 LEVEL height of level (upper boundary) 1000.0 LEVEL height of level (upper boundary) 15000.0 LEVEL height of level (upper boundary)

=====================FORMER RECEPTOR FILE====================

0 NUMRECEPTOR number of receptors

=====================FORMER SPECIES FILE=====================

1 NUMTABLE number of variable properties. The following lines are fixed format

XXXX|NAME |decaytime |wetscava |wetsb|drydif|dryhenry|drya|partrho |parmean|partsig|dryvelo|weight |

AIRTRACER -999.9 -9.9E-09 -9.9 -9.9E09 -9.99 29.00

=====================FORMER RELEEASES FILE===================

1 NSPEC total number of species emitted
0 EMITVAR 1 for emission variation
2 LINK index of species in file SPECIES
1 NUMPOINT number of releases

20110301 000000 ID1, IT1 beginning date and time of release
20110310 000000 ID2, IT2 ending date and time of release

  1. XPOINT1 (real) longitude [deg] of lower left corner
  2. YPOINT1 (real) latitude [deg] of lower left corner
  3. XPOINT2 (real) longitude [deg] of upper right corner
  4. YPOINT2 (real) latitude [DEG] of upper right corner 1 KINDZ (int) 1 for m above ground, 2 for m above sea level, 3 pressure 0 ZPOINT1 (real) lower z-level 18000 ZPOINT2 (real) upper z-level 4000000 NPART (int) total number of particles to be released 1.000E00 XMASS (real) total mass emitted

test NAME OF RELEASE LOCATION

Sorry for the late reply.
Just a reminder: the ozone tracer option is a domain filling option. If used, stratospheric ozone is calculated within the release location you defined based on a Ozone/PV linear relationship above the tropopause.

I see that your release location is too small in your input file. the release location will define the boundaries where the stratospheric ozone is calculated.
The coordinates should define a large release box.
For instance (assuming you use RELEASE_COORD=0)

20110301 000000 ID1, IT1 beginning date and time of release
20110303 000000 ID2, IT2 ending date and time of release
1993500 XPOINT1 (real) longitude [deg] of lower left corner
1021500 YPOINT1 (real) latitude [deg] of lower left corner
4400000 XPOINT2 (real) longitude [deg] of upper right corner
3400000 YPOINT2 (real) latitude [DEG] of upper right corner
1 KINDZ (int) 1 for m above ground, 2 for m above sea level, 3 pressure
0 ZPOINT1 (real) lower z-level
18000 ZPOINT2 (real) upper z-level
1000000 NPART (int) total number of particles to be released

1.000E00 XMASS (real) total mass emitted

test NAME OF RELEASE LOCATION

Can you try that?
Thanks

comment:4 Changed 5 years ago by jbrioude

I check with my own files, and I also get zeros.
A but in the code seems to be the reason. I'll try to fix that asap.

comment:5 Changed 5 years ago by jbrioude

I checked with my own files, and I also get zeros.
A bug in the code seems to be the reason. I'll try to fix it asap.

Changed 5 years ago by jbrioude

Changed 5 years ago by jbrioude

Changed 5 years ago by jbrioude

comment:6 follow-up: Changed 5 years ago by jbrioude

I have a fix.
Can you copy conccalc_reg.f90 and conccalc_irreg.f90 in your FLEXPART-WRF directory, recompile it and try?
It should work now.

comment:7 in reply to: ↑ 6 Changed 5 years ago by sulinust

Replying to jbrioude:
Thanks, it works now. I have another small question, the parameter "LEVEL" in FORMER OUTGRID FILE, is it altitude above ground level or above sea level?

Thanks again.

I have a fix.
Can you copy conccalc_reg.f90 and conccalc_irreg.f90 in your FLEXPART-WRF directory, recompile it and try?
It should work now.

comment:8 Changed 5 years ago by jbrioude

  • Resolution set to fixed
  • Status changed from assigned to closed

For information, the bugfix is at line 75 in conccalc_reg.f90

To answer your question: The levels in the OUTGRID file are meters above ground level. To convert it in levels above sea level, you can use the topography of the output grid available in the header file.

Note: See TracTickets for help on using tickets.
hosted by ZAMG