Opened 3 months ago

Closed 7 weeks ago

#192 closed Support (worksforme)

Issue during install of FLEXPARTv9.3.

Reported by: jaxelsson Owned by:
Priority: major Milestone:
Component: FP coding/compilation Version: FLEXPART 9.3
Keywords: FLEXPART 9.3 makefile install Cc:

Description

Dear all,
I receive error once I run the command "make -f makefile.gfortran:

Josefines-MacBook-Air-2:flexpart_code josefineaxelsson$ make -f makefile.gfortran
gfortran -c -O2 -m64 -mcmodel=medium -fcheck=all -fconvert=little-endian -frecord-marker=4 -I/usr/local/include  -DPERFTIMER class_vtable_mod.F90
gfortran -c -O2 -m64 -mcmodel=medium -fcheck=all -fconvert=little-endian -frecord-marker=4 -I/usr/local/include  -DPERFTIMER grib2check.F90
gfortran -c -O2 -m64 -mcmodel=medium -fcheck=all -fconvert=little-endian -frecord-marker=4 -I/usr/local/include  -DPERFTIMER fpgridcheck.F90
gfortran -c -O2 -m64 -mcmodel=medium -fcheck=all -fconvert=little-endian -frecord-marker=4 -I/usr/local/include  writeheader.f90
gfortran -c -O2 -m64 -mcmodel=medium -fcheck=all -fconvert=little-endian -frecord-marker=4 -I/usr/local/include  assignland.f90
/var/folders/bh/tl9b2kj11qg1cf4vttxlbhp80000gn/T//ccgoJe5a.s:84:2: error: unsupported symbol modifier in relocation
        movabsq $37440000+_xlandusep.3473@GOTOFF, %rax
        ^
make: *** [assignland.o] Error 1

All the paths should be set accordingly in the makefile.gfortran, hence I don't see why there is an error.
Is anyone willing to help me solve it?

Best!

Change History (1)

comment:1 Changed 7 weeks ago by pesei

  • Resolution set to worksforme
  • Status changed from new to closed

This seems to be a bug in the gfortran implementation on MacOS, as Ignacio was writing on the mailing list:


  • This may be linked to the migration of Apple to LLVM (the underlying compilation engine of gfortran in Darwin).
  • Another usual error message in macs is something like: ld: 32-bit RIP relative reference out of range (2184746534 max is +/-4GB):
  • A workaround is to reduce the size of all arrays to the minimum in order to generate a small static executable.
  • Notice that -mcmodel=medium should in principle allow large static executables, but in my experience doesn?t work.

I have tried to contact the gfortran developers but I haven't had any feedback.


As it is not a Flexpart bug, I close this ticket (as worksforme, as it should work in a proper environment).

Note: See TracTickets for help on using tickets.
hosted by ZAMG