Opened 6 years ago

Closed 6 years ago

#103 closed Defect (fixed)

FLEXWRFV3.1 runtime probIems (about IOUTPUTFOREACHREL and NAGECLASS)

Reported by: tauhonson Owned by: jbrioude
Priority: minor Milestone:
Component: FP other Version: FLEXPART-WRF
Keywords: IOUTPUTFOREACHREL Cc: skomo

Description

Hi, everyone
I was able to run FLEXWRF sucessfully, but there was a problem in the flxout output file.

when IOUTPUTFOREACHREL=1 (let NUMPOINT=n), if NAGECLASS>2 then I found that the concentration field caused by previous n-1 release sites of all age classes was only domain-wide ZERO. And if I did nothing except change NAGECLASS to 2, the concentration output for all n release sites were reasonable.

I am not sure if there was a bug within FLEXWRF? I would appreciate if you do me a favor.

Best regards.

Attachments (2)

flexwrf-f1.input (6.9 KB) - added by tauhonson 6 years ago.
fix.tar.gz (8.5 KB) - added by jbrioude 6 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 6 years ago by DefaultCC Plugin

  • Cc skomo added

comment:2 follow-up: Changed 6 years ago by jbrioude

  • Owner changed from somebody to jbrioude
  • Status changed from new to accepted

Hi,
what kind of flexpart output format do you use? binary or netcdf?

Thanks

comment:3 in reply to: ↑ 2 Changed 6 years ago by tauhonson

Replying to jbrioude:

Hi,
what kind of flexpart output format do you use? binary or netcdf?

Thanks

Hi
The output format was netcdf.

comment:4 follow-up: Changed 6 years ago by jbrioude

Can you send the flexwrf.input file you use? It will help to replicate the bug.
Thanks

Changed 6 years ago by tauhonson

comment:5 in reply to: ↑ 4 Changed 6 years ago by tauhonson

Replying to jbrioude:

Can you send the flexwrf.input file you use? It will help to replicate the bug.
Thanks

Please refer to the attachments.
It was from tutoring flexwrf_v31_testcases.I just added some ageclasses.

comment:6 Changed 6 years ago by jbrioude

Okay. yes, there is a problem with the netcdf output because I didn't expect ioutputforeachrel to be used in forward runs.
I will try to write a fix in the coming days.

Changed 6 years ago by jbrioude

comment:7 follow-up: Changed 6 years ago by jbrioude

I have attached a fix. The problem was coming from the loops over release location and ageclasses.
Please try it.
Let us if it fixes your problem.
Thanks

comment:8 in reply to: ↑ 7 Changed 6 years ago by tauhonson

Replying to jbrioude:

I have attached a fix. The problem was coming from the loops over release location and ageclasses.
Please try it.
Let us if it fixes your problem.
Thanks

Hi
It works. Thanks.

comment:9 Changed 6 years ago by jbrioude

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.
hosted by ZAMG