Opened 7 years ago

Closed 7 years ago

#62 closed Support (worksforme)

error reading ECMWF grib files, gridcheck.f90

Reported by: marine Owned by: somebody
Priority: major Milestone:
Component: FP input data Version: FLEXPART 9.0.2
Keywords: gridcheck ecmwf Cc:

Description

Hello,

I have a problem when running Flexpart using ECMWF with a gfortran compiler. An error message appears :

'*ERROR: input file needs to contain GRiB1 formatted messages'

I found that the problem comes from the file "gridcheck.f90":

!
! GET NEXT FIELDS
!
call grib_new_from_file(ifile,igrib,iret)
if (iret.eq.GRIB_END_OF_FILE ) then

goto 30 ! EOF DETECTED

I can not find why it does not work. I can make it work by modifying gridcheck.f90 and writing a list of every name of the wind field that will be used for the run, but this is constraining and I am not sure how many fields are taken into account for the spin up.

Attachments (1)

AVAILABLE_EX (450 bytes) - added by marine 7 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 7 years ago by adityavaishya

Any updates on this issue? I am getting the same error!

comment:2 Changed 7 years ago by marine

Yes, It was just an error in the file AVAILABLE, too many spaces between the different columns.

comment:3 Changed 7 years ago by adityavaishya

Thanks for the quick reply. Can you upload an example AVAILABLE file? If the space is less it gives file error!

Changed 7 years ago by marine

comment:4 Changed 7 years ago by adityavaishya

No luck in changing file format! error continues.
Any lines in the code which indicates the grib type?

comment:5 Changed 7 years ago by pesei

  • Milestone FLEXPART 9.2 deleted

Is the problem solved now?

comment:6 Changed 7 years ago by ignacio

  • Resolution set to wontfix
  • Status changed from new to closed

The error message '*ERROR: input file needs to contain GRiB1 formatted messages' seems not to be issued by FLEXPART but likely by GribAPI. A possible interpretation is that the grib file is ill formatted or corrupted. It is probably not problem of coding but of input.

comment:7 Changed 7 years ago by leohaim

  • Resolution wontfix deleted
  • Status changed from closed to reopened

This problem occurs if one uses the new ECMWFDATA v6 retrieval software that is not yet officially available from FLEXPART.EU but which has been given to a few users
for testing.

In case you specify M_FORMAT=GRIB2, all fields, including surface fields, are converted into GRIB2. The resulting output file can only be read with a patch to the grib_check and a few other input routines.

As a workaround, please specify M_FORMAT=GRIB1. Then the model level fields will still be GRIB2 but the surface fields will be GRIB1. These output files can be read with the current FLEXPART versions.

The new ECMWFDATA v6 retrieval software will be soon officially released together with the needed patch in FLEXPART.

comment:8 Changed 7 years ago by pesei

  • Component changed from FP coding/compilation to FP input data
  • Resolution set to worksforme
  • Status changed from reopened to closed

OK, so I think we can close it as "worksforme". I'also correct the Component field.

Note: See TracTickets for help on using tickets.
hosted by ZAMG