Opened 6 months ago

Closed 4 months ago

Last modified 4 months ago

#240 closed Support (fixed)

FLEXPART-WRF particle height does not change for 16 hours

Reported by: ZhenhuaHao Owned by: pesei
Priority: major Milestone: FLEXPART_WRF_3.4_FPbase_9
Component: FP other Version: FLEXPART-WRF
Keywords: altitude Cc:

Description

Hi there,
I am using flexpart-WRF to simulate particel trajectories and what come out seem unnatural and may be casued by some issues.

The altitudes of all particles keep increasing for first 8 hours (10am to 18) and then remain at exactly same altitude for another 16 hours (18-8) before increasing again. The last recorded altituedes are often far off the ground (above 200 m).

I changes my WRF inputdata to different dates and files but it keeps having the same problem. So could you please be possible to advise any potential issue causing this?

Thank you so much for you help and support in advance.

Cheers,
Iris

Attachments (5)

flexpart_height_10particles.jpg (23.5 KB) - added by ZhenhuaHao 6 months ago.
Variation in altitudes of particles
hanna_1024_10_outof1000_ht.jpg (137.5 KB) - added by ZhenhuaHao 4 months ago.
Variation in altitudes of particles
flexwrf.input.forward_64_new (7.0 KB) - added by ZhenhuaHao 4 months ago.
hanna_1024_50_outof1000_ht.jpg (250.5 KB) - added by ZhenhuaHao 4 months ago.
hanna_1024_1000particles_ht.jpg (148.9 KB) - added by ZhenhuaHao 4 months ago.

Download all attachments as: .zip

Change History (15)

Changed 6 months ago by ZhenhuaHao

Variation in altitudes of particles

comment:1 Changed 4 months ago by ZhenhuaHao

Hi there

This seems to be a major defect and requires close attention. Could you please advise on this issue.

Regards

comment:2 Changed 4 months ago by pesei

  • Component changed from FP post-processing to FP other
  • Milestone set to FLEXPART_WRF_3.4_FPbase_9
  • Priority changed from minor to major
  • Summary changed from Flexpart output doesnt change height for 16 hours to FLEXPART-WRF trajectory output - height does not change for 16 hours
  • Type changed from Support to Defect

Thank you for reporting the issue. Unfortunately, we don't have a lot of resources at this time, especially with respect to the WRF version.

Have you dumped particle positions to check whether they have the same problem as the trajectories (which are created by clustering of particle positions)? This would help to narrow down the problem. Without a test data set for us to play it will be difficult to find the cause.

comment:3 Changed 4 months ago by ZhenhuaHao

Thanks for your response. I dumped the particles every output interval and that's how I see the altitude variation.

I didn't use trajectories to check if they have the same problem as I do not find ways to read trajectory files. Can you let me know how to read those files? I will see if it could help narrow down the problem.

thank you so much!

comment:4 Changed 4 months ago by pesei

  • Summary changed from FLEXPART-WRF trajectory output - height does not change for 16 hours to FLEXPART-WRF particle height does not change for 16 hours

comment:5 Changed 4 months ago by pesei

Thank you for the clarification. Your plot shows only very few particles. How many are you using? Maybe you want to post your input file? Why don't we see turbulent mixing in the boundary layer?
I would do a run with maybe 1000 paricles, dump their position every 300 s, and then make a scatter plot z vs t (line plot will not be useful - we would see only lines but no particle positions).

Then, to find out what really happens, it would be advisable to insert print statemens showing the mean and the turbulent vertical velocities. Have you already plotted the vertical velocities in your WRF output?

Changed 4 months ago by ZhenhuaHao

Variation in altitudes of particles

Changed 4 months ago by ZhenhuaHao

Changed 4 months ago by ZhenhuaHao

comment:6 Changed 4 months ago by ZhenhuaHao

Thank you for your response.

Yes my plot only had 10 particles. Now based on your suggestions, I reran the simulation with 1000 particles and 300 s time interval (the input files is uploaded) and then plotted the first 10 or 50 of the 1000 particles and can still see some of them experiencing the same problem once they reach the 100 m above ground during certian time period.

I had simulation with other time and date but it showed same problem. The turbulance is generated by flexpart rather than WRF (it keeps causing error if I set the input terbulance variables are from WRF, i.e. SFC_OPTION=1) so I suspect it is something wrong with the flexpart rather than WRF.

Please let me know if you find anything suspicious in the input file.

ALso, can you advise where to insert print statemens showing the mean and the turbulent vertical velocities if you think this could help?

Thank you so much,

Iris

Changed 4 months ago by ZhenhuaHao

comment:7 Changed 4 months ago by pesei

I think there is nothing wrong. During the night the boundary layer height goes below 100 m, but as there is a hmixmin (which I think is set to 100 m), particles above 100 m stop undergoing turbulent motion. And at 100 agl over flat terrain grid-scale vertical velocity will be very small.

comment:8 Changed 4 months ago by pesei

  • Owner set to pesei
  • Status changed from new to accepted
  • Type changed from Defect to Support

comment:9 Changed 4 months ago by pesei

  • Resolution set to fixed
  • Status changed from accepted to closed

Looks like solved, so close the ticket. If you still have an issue, you could ask for reopening.

comment:10 Changed 4 months ago by ZhenhuaHao

Thank you so much for your kind answer and help.

I could now resolve the problem. The main problem I had was caused by dry deposition velocity failed to be read from the input file. This was solved by using option of giving density, diameter and std of the particles.

This bug should be mentioned in somewhere or the reading of dry deposition velocity from input file should be removed.

Last edited 4 months ago by ZhenhuaHao (previous) (diff)
Note: See TracTickets for help on using tickets.
hosted by ZAMG