Opened 3 months ago

Closed 5 weeks ago

#215 closed Defect (fixed)

Bug in flex_extract v7.0.3 ERA5 data extraction

Reported by: anphi Owned by: anphi
Priority: blocker Milestone:
Component: flex_extract Version: flex_extract_v7.0.3
Keywords: ERA5 Cc:

Description

Recently, I found out that flex_extract version 7.0.3 has an error in the extraction of ERA5 data!

PLEASE STOP USING ERA5 DATA EXTRACTION!!!!

Times 17 and 18 do not contain any flux fields (e.g. precipitation).
And the rest of the times it seems that the flux fields are shifted in time.

I'll provide a bug fix as soon as possible!

Explanations will follow ...

Change History (9)

comment:1 Changed 3 months ago by pesei

  • Status changed from new to assigned

comment:2 Changed 3 months ago by ahilboll

Hi, thanks for the warning! Can you please announce on the mailing list once it's fixed? I just found out about this problem accidentally while I was browsing the timeline ...

comment:3 Changed 3 months ago by anphi

Yes, I will!

comment:4 Changed 6 weeks ago by ahilboll

I'm just guessing here (don't have the time to really get into this at the moment), but could it be that in ll. 1468 of FlexpartTools.py,

if not (step==c.maxstep and c.maxstep>12 or sdates==elimit):
    vdp.pop(0)
    svdp.pop(0)

there's something wrong? It seems strange to pop from vdp as well here. But then again, I don't really know what I'm talking about ...

comment:5 Changed 5 weeks ago by anphi

This should be the correct behavior. We are going over the time series keeping just the last 4 time steps in these vpd and svdp lists.

comment:6 Changed 5 weeks ago by pesei

  • Milestone set to flex_extract_v7.1

comment:7 Changed 5 weeks ago by anphi

  • Milestone flex_extract_v7.1 deleted

comment:8 Changed 5 weeks ago by anphi

The problem is solved and the bugfix version is announced as 7.0.4 through the mailing list.
I am closing the ticket.

comment:9 Changed 5 weeks ago by anphi

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.
hosted by ZAMG