Opened 3 years ago

Closed 2 years ago

#165 closed Support (fixed)

a lot of NaNf in flexwrf output data

Reported by: tyang Owned by: jbrioude
Priority: major Milestone: FLEXPART_WRF_3.2_FPbase_9
Component: FP input data Version: FLEXPART-WRF
Keywords: Cc:

Description

hi,

I had some problems with flexwrf, most of output data were NaNf?(while some are "inf"),the program didn't give any errors or warnings. I tried to checked the input file but couldn't find the reason.Could you help me?
Some of input and output files are attached below(I have convert .nc files to .txt files for reading), thank you!

File list:

  1. namelist.wps and namelist.input(input file for wps and WRF)
  2. flexwrf.input(input file for flexwrf)
  3. output_message.txt(output message of flexwrf with verbose=100)
  4. header_d01.txt (output header file of flexwrf)
  5. flxout_d01_20150716_030000.txt(one of output files of flexwrf)

Attachments (6)

namelist.wps (1.4 KB) - added by tyang 3 years ago.
namelist.input (7.7 KB) - added by tyang 3 years ago.
flexwrf.input (8.4 KB) - added by tyang 3 years ago.
output_message.txt (36.0 KB) - added by tyang 3 years ago.
header_d01.rar (42.0 KB) - added by tyang 3 years ago.
flxout_d01_20150716_030000.rar (10.4 KB) - added by tyang 3 years ago.

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by tyang

Changed 3 years ago by tyang

Changed 3 years ago by tyang

Changed 3 years ago by tyang

Changed 3 years ago by tyang

Changed 3 years ago by tyang

comment:1 Changed 3 years ago by tyang

I changed outgrid_coord and release_coord to 1,then the problem was solved, but I don't know why. If I want to set outgrid to 0 and use WRF grid, should I change OUTLONLEFT and OUTLATLEFT? And how to change them?

Last edited 3 years ago by tyang (previous) (diff)

comment:2 Changed 3 years ago by jbrioude

Hi Tyan,
you use OUTGRID_COORD=0 and RELEASE_COORD=0 while you define your outgrid and release box coordinates as latitude/longitude. if you use OUTGRID_COORD=0 and RELEASE_COORD=0 , then you have to define your grids in meters within the WRF grid.

I noticed that you defined your vertical levels with very high altitude. The last level is 201300.0m. I assume that it's an error in your altitude level definition, probably a "0" should be removed for each vertical level.

Regards,
Jerome

Last edited 3 years ago by jbrioude (previous) (diff)

comment:3 Changed 3 years ago by tyang

Thank you very much, I still don't understand how to "define my grids in meters within the WRF grid" using OUTLONLEFT and OUTLATLEFT.
For example, if I use OUTGRID_COORD=1 and RELEASE_COORD=1,the WRF grid is 20*20*3,while grid distance is 1 km in both x and y direction, my questions are:

  1. Should I set DXOUTLON and DYOUTLON to 0.01 or 3000 with OUTGRIDDEF to 0?
  2. How should I set OUTLONLEFT and OUTLATLEFT?

comment:4 Changed 3 years ago by pesei

  • Owner set to jbrioude
  • Status changed from new to assigned

comment:5 Changed 2 years ago by pesei

  • Resolution set to fixed
  • Status changed from assigned to closed

I guess the issue is solved, as there is no more comment.

Note: See TracTickets for help on using tickets.
hosted by ZAMG