Opened 3 years ago

Closed 3 years ago

#153 closed Defect (duplicate)

Problem while installing flexpart

Reported by: mdayan Owned by: pesei
Priority: major Milestone:
Component: FP coding/compilation Version: FLEXPART 9.0.2
Keywords: Cc:

Description

Dear Sir/Ms?,

I am trying to install flexpart in our system.
The changes I have made in the Makefile are:

# diff makefile.ecmwf_gfortran Makefile
6,8c6,8
< INCPATH = /xnilu_wrk/flex_wrk/bin64/grib_api/include
< LIBPATH1 = /xnilu_wrk/flex_wrk/bin64/grib_api/lib
< LIBPATH2 = /flex_wrk/flexpart/lib64/gfortran/lib/
---

INCPATH = /usr/local/include
LIBPATH1 = /usr/lib64
LIBPATH2 = /usr/lib64

During make I receive this error

# make

gfortran -c -O2 -m64 -mcmodel=medium -fconvert=little-endian -frecord-marker=4 -I/usr/local/include erf.f90
erf.f90:106.26:

real, external
gammln 1

Error: Return type mismatch of function 'gammln' at (1) (REAL(4)/REAL(8))
erf.f90:111.13:

gln=gammln(a)

1

Warning: Type mismatch in argument 'xx' at (1); passed REAL(4) to REAL(8)
erf.f90:140.26:

real, external
gammln 1

Error: Return type mismatch of function 'gammln' at (1) (REAL(4)/REAL(8))
erf.f90:145.13:

gln=gammln(a)

1

Warning: Type mismatch in argument 'xx' at (1); passed REAL(4) to REAL(8)
make: * [erf.o] Error 1

I would appreciate your help with the installation.

Regards,
Melina Dayan
Israel Meteorological Service

Change History (2)

comment:1 Changed 3 years ago by pesei

  • Component changed from FP other to FP coding/compilation
  • Owner set to pesei
  • Status changed from new to accepted

comment:2 Changed 3 years ago by pesei

  • Resolution set to duplicate
  • Status changed from accepted to closed

This is a duplicate of #49. You will find the solution there.

PS. Please used trac code block syntax for quoting code
{{{

code

}}}
There's also a little icon on the edit window for that. For inline code, use

`code`
Note: See TracTickets for help on using tickets.
hosted by ZAMG