Opened 10 months ago

Last modified 10 months ago

#221 accepted Support

Issue while running FLEXPART 9.0 with FNL 2014 and earlier years data.

Reported by: arajst Owned by: pesei
Priority: major Milestone:
Component: FP input data Version: FLEXPART 9.0
Keywords: FNL data, FLEXPART 9.0, GRIB_API Cc: stakhilraj@…, sanjeev.esa@…

Description

Dear all,

I am facing a problem while running FLEXPART 9.0 with FNL 2014 and earlier years data. It is showing the following error message.

GRIB_API ERROR : JPEG support not enabled.
GRIB_API ERROR : unable to get codedValues as double array (Function not yet implemented)
GRIB_API ERROR : gridcheckwind_gfs: Error Function not yet implemented.

However, the model is running perfectly with 15 January 2015 onward.
While posting this issue we noticed a related issue by Dr. Harish from Ahmedabad regarding FNL data from 14 January 2015
(https://www.flexpart.eu/ticket/220).

Kindly suggest some solution to resolve this problem.

With regards

Akhil

Change History (9)

comment:1 Changed 10 months ago by pesei

Maybe you need a newer version of the grib_api, and you have to make sure that support for jpeg compression is activited in compiling the grib library.

comment:2 Changed 10 months ago by arajst

Thank you Pesei for your kind reply. We are using Grib_api1.26.1-source. We configured it without enabling jpeg, otherwise, it is not installing. Could you please suggest a method for the clean installation of grib_api higher version with JPEG enabled option. The following command we used for the installation of Grib_api

cmake ../grib_api-1.26.1-Source -DCMAKE_INSTALL_PREFIX=/home/akhil/flexpart/GRIB_API -DBUILD_SHARED_LIBS=OFF -DENABLE_JPG=ON.

comment:3 Changed 10 months ago by pesei

  • Owner set to pesei
  • Status changed from new to accepted

I assume that you are on a Linux system. In Debian & its derivatives, there is a package libgrib2c0d which includes jpeg. You can also use eccodes (then you need to change your loader flags in the makefile accordingly).

comment:4 Changed 10 months ago by arajst

Thank you for your kind reply. I am using Ubuntu 18.04LTS. I will follow the steps and update you soon.

comment:5 Changed 10 months ago by pesei

All ok?

comment:6 follow-up: Changed 10 months ago by arajst

Dear Pesei, Sorry for the delay in replying. I have tried to install eccode using the following steps

cmake /home/akhil/flexpart/eccodes-2.10.0-Source -DCMAKE_INSTALL_PREFIX=/home/akhil/flexpart/build2

this step it ran successfully, however, while running 'make' it's giving the following error,

[ 60%] Building C object src/CMakeFiles/eccodes.dir/grib_yacc.c.o
[ 60%] Building C object src/CMakeFiles/eccodes.dir/grib_lex.c.o
[ 60%] Linking C shared library ../lib/libeccodes.so
/home/akhil/flexpart/jasper-1.900.1/lib/libjasper.a(jas_stream.o): In function `jas_stream_tmpfile':
/home/akhil/flexpart/jasper-1.900.1/src/libjasper/base/jas_stream.c:368: warning: the use of tmpnam' is dangerous, better use mkstemp'
/usr/bin/ld: /home/akhil/flexpart/jasper-1.900.1/lib/libjasper.a(jas_icc.o): relocation R_X86_64_PC32 against symbol `jas_iccprof_destroy' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
src/CMakeFiles/eccodes.dir/build.make:9691: recipe for target 'lib/libeccodes.so' failed
make[2]: * [lib/libeccodes.so] Error 1
CMakeFiles/Makefile2:1179: recipe for target 'src/CMakeFiles/eccodes.dir/all' failed
make[1]:
* [src/CMakeFiles/eccodes.dir/all] Error 2
Makefile:162: recipe for target 'all' failed
make: * [all] Error 2

comment:7 in reply to: ↑ 6 Changed 10 months ago by pesei

Why don't you install the package from your Linux distribution as I recommended?

comment:8 Changed 10 months ago by arajst

Dear Pesei thank you for the fast reply. I tried to install libgrib2c0d for ubuntu. It didn't install. That's why I moved to eccode. The main thing is that i am not much familiar with Linux.

comment:9 Changed 10 months ago by pesei

What means "it did not install"? What exactly happened? And why are you again not trying the distribution package for eccodes?

(And please use proper trac syntax if you post code snippets or similar.)

Note: See TracTickets for help on using tickets.
hosted by ZAMG