Opened 3 years ago

Closed 3 years ago

#167 closed Support (fixed)

Running test cases with FLEXPART-WRF

Reported by: victoria.sinclair@… Owned by: adingwell
Priority: minor Milestone:
Component: FP input data Version: FLEXPART-WRF
Keywords: Cc:

Description

I am new to FLEXPART-WRF and I am trying to run the test cases. I have sucessfully compiled the code (no error messages and I have an executable). I have downloaded the test WRF input data. However when I run the following command

./flexwrf32_gnu_serial flexwrf.input.forward1

I get the following error:

the input file used is flexwrf.input.forward1 Pre-generating random numbersCalling readinput

Opening 'flexwrf.input.forward1 ' for reading
Reading pathnames

At line 236 of file readinput.f90 (unit = 1, file = 'flexwrf.input.forward1')
Fortran runtime error: Bad integer for item 1 in list input

The only changes I made to the input file were to change the pathnames at the very top. I have attached the file and the AVAILABLE file I am using.

Attachments (2)

AVAILABLE2 (1.5 KB) - added by victoria.sinclair@… 3 years ago.
flexwrf.input.forward1 (7.1 KB) - added by victoria.sinclair@… 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by victoria.sinclair@…

Changed 3 years ago by victoria.sinclair@…

comment:1 Changed 3 years ago by adingwell

  • Priority changed from major to minor

There is a problem in an earlier release where a new option was added to the input file (but not to testcase files). Try using the latest version (3.3.1):
https://www.flexpart.eu/downloads/57

It would probably work by simply using the *.input files from the newest release but there are a number of bugfixes included so I would recommend reinstalling.

comment:2 Changed 3 years ago by victoria.sinclair@…

Thanks for your quick reply.

I have now re-compiled with Version 3.3.1. I still have a problems. First, I had to change SFC_OPTION from 1 to 0 in flexwrf.input.forward1. This removed the first error that reading from WRF was not supported. Second, I needed to copy the files from data directory but there was no data directory in the tar.gz file for v3.3.1. I used those from v3.3. Now I have an error I don't know how to fix:

Allocating fields for nested and global output (x,y): 24 28
Error: Permission denied

Any suggestions?

comment:3 Changed 3 years ago by adingwell

This is probably not an error from the variable allocation.
Have you checked that you have read/write permissions to all files in your working directory and in your paths?

comment:4 Changed 3 years ago by victoria.sinclair@…

I had checked the permissions which were all ok. I have now found the cause of the error - the output pathname in the AVAILABLE2 file had a typo in it so the model was trying to write a file to a directory which did not exist. Hence, the permission error.

Thanks again for you help - I now have successfully run the first forward test case.

comment:5 Changed 3 years ago by pesei

  • Owner set to adingwell
  • Status changed from new to assigned
  • Type changed from Support to Defect

comment:6 Changed 3 years ago by pesei

  • Resolution set to fixed
  • Status changed from assigned to closed
  • Type changed from Defect to Support
Note: See TracTickets for help on using tickets.
hosted by ZAMG