Opened 3 years ago

Closed 3 years ago

#141 closed Support (fixed)

Bad value during integer read. readavailable.f90

Reported by: rbarragan Owned by: pesei
Priority: major Milestone:
Component: FP input data Version: FLEXPART 9.0.2
Keywords: readavailable Cc:

Description

Hello,
when i run flexpart after configure the COMMAND file and generate the AVAILABLE file, i have the following error:
at line 99 of file readavailable.f90 (uni=1, file 'path to AVAILABLE file')
Fortran runtime error: Bad value during integer read.

The first line about the windfield file in my AVAILABLE file looks like this:
20130614 120000 2013/201306141200.cdas1.20130614.pgrbh.grb2

Change History (4)

comment:1 Changed 3 years ago by pesei

  • Component changed from FP other to FP input data
  • Owner set to pesei
  • Priority changed from critical to major
  • Status changed from new to accepted
  • Type changed from Defect to Support

In FLEXPART 9.0.2, lines 98/99 of readavailable.f90 read as follows

100   read(unitavailab,'(i8,1x,i6,2(6x,a255))',end=99) &
           ldat,ltim,fname,spec

This does not agree with your quotation. Please paste your full line 99 or the whole read statement, using trac syntax for code (see little icons above the edit window).

How did you produce the AVAILABLE file? Does ist include the spec string ("ON DISC")?

comment:2 Changed 3 years ago by pesei

btw, have you seen FpInputMkavail? ?

comment:3 Changed 3 years ago by pesei

Is the problem solved?

comment:4 Changed 3 years ago by pesei

  • Resolution set to fixed
  • Status changed from accepted to closed

No answer by reporter since 5 months, I guess the problem is solved.

Note: See TracTickets for help on using tickets.
hosted by ZAMG