Opened 6 years ago

Closed 5 years ago

#127 closed Support (fixed)

Error loading shared libraries

Reported by: srvsxc Owned by: pesei
Priority: major Milestone:
Component: FP other Version: FLEXPART 9.0.2
Keywords: Cc:

Description

Hi all,

I don't get any error while compiling Flexpart. But while executing I get the following message,

./FLEXPART_GFS: error while loading shared libraries: libgrib_api_f90.so.0: cannot open shared object file: No such file or directory.

Here is a part of my makefile. Note: libgrib_api_f90.so.0 does exist in the LIBPATH1 in makefile.

SHELL = /bin/bash
MAIN = FLEXPART_GFS
INCF    = incl*
#

FC       = ifort
INCPATH  = /gpfs1/home/Libs/INTEL/GRIB_API/include
LIBPATH1 = /gpfs1/home/Libs/INTEL/GRIB_API/lib

LIBPATH2 = /gpfs1/home/Libs/INTEL/JASPER/jasper-1.900.1/lib

FFLAGS   =   -O3 -r8 -I$(INCPATH) -mcmodel=medium

#LDFLAGS  = $(FFLAGS) -L$(LIBPATH2) -L$(LIBPATH1) -lgrib_api_f90 -lgrib_api -lm -ljasper
LDFLAGS  = $(FFLAGS) -L$(LIBPATH1) -lgrib_api_f90 -lgrib_api -L$(LIBPATH2) -lm -ljasper
#

Attention please!! Thank you in advance.

Change History (10)

comment:1 Changed 6 years ago by pesei

  • Owner set to pesei
  • Status changed from new to accepted

The lib file should be called libgrib_api_f90.so (not .1)

Btw, nothing FLEXPART-specific here ...

comment:2 Changed 6 years ago by srvsxc

Thank you pesei for your reply.

But, I dint get you. The lib file I have used is -lgrib_api_f90. Can you please help me further.

comment:3 follow-up: Changed 6 years ago by pesei

You are saying Note: libgrib_api_f90.so.0 does exist in the LIBPATH1 in makefile. Your shared-object lib file must be named libgrib_api_f90.so, not libgrib_api_f90.so.0.

comment:4 in reply to: ↑ 3 Changed 6 years ago by srvsxc

Replying to pesei:

You are saying Note: libgrib_api_f90.so.0 does exist in the LIBPATH1 in makefile. Your shared-object lib file must be named libgrib_api_f90.so, not libgrib_api_f90.so.0.

Okay. The shared-object lib file libgrib_api_f90.so also exist in the same path. Can you please suggest something to avoid this error message.

comment:5 follow-up: Changed 6 years ago by pesei

I can't do remote diagnostics on your system. Have you made sure that your lib was compiled with the same compiler as your FLEXPART code? I see that you are using ifort for FLEXPART, but most Linux systems will by default use gcc if you build software.

comment:6 in reply to: ↑ 5 Changed 6 years ago by srvsxc

Replying to pesei:

I can't do remote diagnostics on your system. Have you made sure that your lib was compiled with the same compiler as your FLEXPART code? I see that you are using ifort for FLEXPART, but most Linux systems will by default use gcc if you build software.

Yes, grib_api was built with the intel compiler only.

comment:7 follow-up: Changed 6 years ago by pesei

Maybe it's something related to your LD_LIBRARY_PATH environment variable? Please try to get help from your sysadmin - it is obviously not really a FLEXPART problem and I think it my ideas are exhausted.

comment:8 in reply to: ↑ 7 Changed 6 years ago by srvsxc

Replying to pesei:

Maybe it's something related to your LD_LIBRARY_PATH environment variable? Please try to get help from your sysadmin - it is obviously not really a FLEXPART problem and I think it my ideas are exhausted.

Yeah. I will check further. Thanks :)

comment:9 Changed 6 years ago by pesei

  • Milestone FLEXPART 9.2 deleted

comment:10 Changed 5 years ago by pesei

  • Resolution set to fixed
  • Status changed from accepted to closed

No answer since 10 months, so I assume the problem is fixed.

Note: See TracTickets for help on using tickets.
hosted by ZAMG